Page 1 of 1

Solved: SP3 HDMI board failures for lossless multich formats

Posted: Sat Jun 03, 2017 9:24 pm
by Bert de Jong
Has anyone had crashes of the SP3 HDMI boards when attempting to decode DD THD and/or DTS MA HD? I've had this issue with 3-4 versions of firmware since 2016 including the latest in 2017. Last summer I returned the unit to Bryston for repair under an RMA for these HDMI board crashes and at the time I didn't know what had caused it. No HW failure was found on the bench, but they replaced the HDMI board and sent it back. Afterwards and until recently I had watched very few blurays and when I did a very few of those had lossless audio and the crash occurred. I incorrectly attributed those crashes to my aging Samsung bluray player and took no action. When I finally attempted to watch new UHD blurays with a new Oppo bluray player, the two disks I had both had lossless audio (one DD THD and the other DTS MA HD) and the problem immediately returned. I sent a bunch of observations to Mike Pickett at Bryston over a month ago, but haven't received any SW solutions nor a suggestion that I need a second RMA for this problem. I want to start watching these UHD blurays and others in the near future, but I don't have a stable SP3 that's up to the task. I started hunting online and I couldn't find anyone else with the same problem; not sure if I just missed it or if I'm in unique situation.

Lastly, I somehow lost all my earlier versions of firmware when reformatting HD's; I had upgraded each time over the past 5 years. I couldn't find any of these older firmware versions online and would like to try them. I didn't have this issue with crashing HDMI boards when decoding the lossless multichannel audio formats earlier than 2016. I'd appreciate it if anyone could point me to those.

Here's the recent data I sent to Bryston.

Hi Mike: I found and installed 2017.03j 21 MkIV today, but get similar failure conditions. The HDMI board still crashes after a short time (< minute) instead of crashing instantly when using 2016.04b. For both versions of firmware I could get DTS MA HD converted to 7.1 LPCM in the blu ray player to remain locked most of the time, but could never get 7.1 LPCM conversion of DD THD to work (nor could I get the two lossless bit streams to ever work) with the above two firmware versions.

In the past with earlier versions of firmware (don’t remember which ones) I could get these lossless formats to work with HD blu rays, but I couldn’t find earlier firmware versions online anymore to try it. This search is how I came across the 2017.03j 21 MkIV version. I should think that downgrading isn’t really the answer, but I’m reaching the end of the rope.

Because you left a Gen 1 4K board in my SP3 after the last repair attempt, I made the assumption that HDMI port 8 was the only one that supported higher throughput, so I tried all this with the blu ray player connected to that port…a long shot considering I’m only streaming audio and no video on that secondary output from the blu ray player. No difference.

SP3 Diag1.png
diag when using 2017.03j 21 MkIV
SP3 Diag1.png (117.84 KiB) Viewed 3954 times

Sent from Mail for Windows 10

From: Bert de Jong
Sent: Sunday, May 21, 2017 1:45 PM
To: Mike Pickett
Subject: Re: Failed HDMI Board in SP3

Hi Mike. What's the update? It's been more than a month and I haven't heard a thing.

I thought I'd try to watch a blu ray again, and my SP3 crashed a dozen times last night as I tried and retried to get it to lock up to the Dolby HD audio track of The Martian in UHD. Each time only unplugging the power cable would clear the failure condition. I even went as far as isolating the SP3 and blu ray player from the rest of my home theatre system, including the switching power bar; just the two devices with one interconnecting HDMI cable and the two power cables plugged into the wall...same result. I didn't really expect a different result, but I tried it anyway.

Bert de Jong, P. Eng

Get Outlook for iOS
From: Bert de Jong
Sent: Wednesday, April 12, 2017 2:52 PM
Subject: RE: Failed HDMI Board in SP3
To: Mike Pickett

Hi Mike:

14. In case it helps your engineer, I’ve added a short 30s video demonstrating the aftermath of the problem (mentioned in #9 below) using an older Samsung HD bluray player streaming DTS HDMA. There is a new data point where the Dot Matrix shows “NO” and nothing else. I don’t always see "NO” on the display, but have seen it numerous times. The disk played all it’s trailers in DD caused no problems for the SP3, but as soon as the audio output switched to DTS HDMA the SP3 reset. This happened on the first shot of this experiment.
br. Bert

Sent from Mail for Windows 10

From: Bert de Jong
Sent: Tuesday, April 11, 2017 5:47 PM
To: Mike Pickett
Subject: RE: Failed HDMI Board in SP3

Thanks Mike.
Get Outlook for Android

From: Mike Pickett
Sent: Tuesday, April 11, 2017 3:07:48 PM
To: 'Bert de Jong'
Subject: RE: Failed HDMI Board in SP3

Hi Bert;

Thanks for the video and the detailed fault description. I’ve asked our engineer to go through it as well, and if he thinks we can solve this with a software update, I’ll get the required files to you ASAP.



From: Bert de Jong
Sent: Saturday, April 08, 2017 5:06 PM
To: Mike Pickett
Subject: RE: Failed HDMI Board in SP3

Date: 9 Apr 17

Hi Mike:

I’m having HDMI board failures again. Please have a look at my new 16 minute video which shows the HDMI board failure issue; what causes it, it’s effects, and how I clear it. The video doesn’t show exhaustive troubleshooting, but demonstrates the issue I’m seeing reasonably well and I have more data than I did the first time this happened last summer.
The severe video compression makes the dot matrix display hard to read; I do have some audio commentary of my observations. I attempt to show how the failures are caused and cleared.

Additional data:
1. SP3 - 303
2. SP3 Firmware: u2016.04b used in video; although I saw the same issues with the factory installed (during repair timeframe last August) u2015.09a, which is why I upgraded the firmware in the first place
3. Connected equipment (all running their latest firmware):
a. Bluray player – Oppo UDP 203 UHD - Using second audio-only HDMI 1.4
b. PVR – Bell - HDMI 1.3 or 1.4 (not sure which)
c. TV – LG OLED 65E6P – SPDIF Optical
d. Mac Mini (2016 model) USB/HDMI 2.0
e. All very new, quality HDMI cables (2016/2017); I’ve tried several cables and changed inputs on SP3, but behavior remains the same
f. Bluray to TV direct is HDMI 2.0
4. SP3, PVR and bluray players all plugged into same power bar; TV on same 15A cct but not on same power bar
5. I don’t have issues for lossy DD sources (Mac, Bluray, Bell PVR , OTA and Apps on the TV such as Netflix, YouTube and Amazon Prime)
6. Lossless audio bitstream (DD TrueHD and DTS HDMA) from bluray player will automatically cause an HDMI board reset every time; an LPCM multichannel stream from the bluray player worked for a while without causing resets, but not anymore; the last few iterations using LPCM resulted in a message “DSP not responding, resetting….” followed by an HDMI board failure.
7. After all this I did a hard reset one more time, put in an older bluray with lossy DD bitstream (and also tried multichannel LPCM using this source) and everything works as it should.
8. I even tried HDMI-PCM-192k = DISABLE for the lossless bitstream, but it didn’t change anything, so I left it set to ENABLE (the setting in the video)
9. Same issues have been seen several times on older Samsung bluray player when playing the lossless audio formats; also happened once using bitstream from a Mac Mini over HDMI; no issues streaming LPCM stereo audio over USB from Mac
10. One last note: between August and now I watched very little in the way of blurays with lossless audio; as mentioned I did see the odd event (several) but didn’t try to understand what I was seeing until now and after connecting a new UHD bluray player; I must admit I previously blamed it on the old Samsung bluray player, but that turned out to be an incorrect conclusion
11. Your technician never did find the smoking gun last August as he couldn’t reproduce the issue. I’m not sure if your test benches are also equipped with consumer media devices such as bluray players and such and whether you can reproduce an approximation of my config at home. The end result of the previous RMA was that the HDMI board was replaced without a definitive cause ever having been found.
12. Could this be a firmware/config issue? I generally use default settings, with customizations to speaker sizes, distances, levels mainly. I don’t mess with the expert settings.
13. It’s rather hard to believe that it has been an HDMI board HW issue both times, especially considering the previous cause was never really found. Is there other beta firmware I can try or expert settings changes I can make here before sending this thing away for repair for several weeks; I must admit I’m concerned that the problem may not be reproduced on the bench again; I’m running out of warranty end of this summer and I really need this solved.

Thanks in advance for your help.
Bert de Jong

Sent from Mail for Windows 10"

Re: SP3 HDMI board failures for lossless multich formats

Posted: Thu Aug 10, 2017 3:13 pm
by Bert de Jong
Solved: It was a hardware problem that got fixed by Bryston.