SP3 Manual In Need of Update

Discuss Bryston's SP3 surround processor

SP3 Manual In Need of Update

by mtstewdog » Mon Jun 05, 2017 7:45 pm

I have a relatively new SP3 (Serial #874) purchased this past February. A couple days ago I performed a firmware update and allowed the unit to reset the config to defaults at the conclusion of the update process. Upon completion of system reboot, I began to reenter my custom config, i.e. speaker distances, digital sources, etc. Since I had both side and back surround speakers, I went into SOURCE SETUP > SPEAKER SIZE and appropriately changed FRONT to LARGE, CENTER to LARGE, and BACK to 2 SMALL. The only setting of the four to remain at factory default was SURROUND as SMALL.

Later that day, I noticed (by virtue of the "PLIIx Cin 5.1" in the display) that apparently the SOURCE SETUP > SPEAKER SIZE > BACK had changed to NONE. In fact, all speaker settings were back to their factory defaults of SMALL, SMALL, SMALL and NONE (for FRONT, CENTER, SURROUND and BACK, respectively). I really thought I had a problem that my SP3 was no longer keeping its customized settings for these config options that I was invoking. Yet all other settings that I had changed from default, such as speaker distances, were stable.

My plan was to call Bryston Tech Support this (Monday) morning. However, before I picked up the phone to call them, it occurred to me that it would be helpful if I could better determine just when the SP3 was actually changing back. Was it when there was a source change? Was it when the unit was powered off and back on? Or was it something else altogether?

To that end, I powered up my system, choosing the DirecTV satellite receiver as the source, which is where it was when we turned it off last night before turning in for the night. Seeing "PLIIx Cin 7.1" in the display immediately told me that my speaker settings were still as I had set them: LARGE, LARGE, SMALL, 2 SMALL. Then I switched to another video source and this time I saw "PLIIx Cin 5.1". I quickly went into SOURCE SETUP > SPEAKER SIZE and sure enough, factory defaults. However, then I went back to the original source and now the display showed "PLIIx Cin 7.1". I went back into SOURCE SETUP > SPEAKER SIZE and verified that now the settings were as I customized them.

That's when the "light bulb" went on. I realized that my speaker settings were not "changing" per se. Rather, the behavior was as if the speaker settings needed to be set up for each source INDIVIDUALLY. Then I remembered the setting SOURCE SETUP > OTHER > SRC PAR (which is short for "Source Parameters"), which has two choices: "GLOBAL or INDIVIDUAL". The factory default is apparently INDIVIDUAL. All I had to do was change SRC PAR to GLOBAL and now my speaker size settings were the same for all sources and no longer appeared to be behaving as if they were "changing by themselves".

The setting that caused me an entire weekend of grief, "SRC PAR" is not documented anywhere, or at least not that I could find. The most current version of the SP3 manual says nothing about it, my guess is that because this particular setting was a feature that was added subsequent to the manual (this version of it anyway) being published. I had to rely on brute "mind power" to figure it out on my own.

So here is my point to this entire dialog: Is there a new, updated SP3 manual in the works, one that actually includes documentation for ALL setup/menu options? If not, this really should be moved to the top of the priority list.

Thank You!
mtstewdog
 
Posts: 1
Joined: Sun Jun 04, 2017 7:33 pm

Return to SP3

Who is online

Users browsing this forum: No registered users and 2 guests

cron